What’s Vulnerable › Vulnerabilities
CVE-2020-15135: CSRF vulnerability in save-server
- Severity: high (CVSS 7.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-08-04 · updated 2026-06-17
- Weakness: CWE-352
Description
save-server (npm package) before version 1.05 is affected by a CSRF vulnerability, as there is no CSRF mitigation (Tokens etc.). The fix introduced in version version 1.05 unintentionally breaks uploading so version v1.0.7 is the fixed version. This is patched by implementing Double submit. The CSRF attack would require you to navigate to a malicious site while you have an active session with Save-Server (Session key stored in cookies). The malicious user would then be able to perform some actions, including uploading/deleting files and adding redirects. If you are logged in as root, this attack is significantly more severe. They can in addition create, delete and update users. If they updated the password of a user, that user's files would then be available. If the root password is updated, all files would be visible if they logged in with the new password. Note that due to the same origin policy malicious actors cannot view the gallery or the response of any of the methods, nor be sure they succeeded. This issue has been patched in version 1.0.7.
Affected products
- Neztore save-server: before 1.0.5 — fixed in 1.0.5
How to fix
Upgrade to a fixed version: Neztore save-server 1.0.5. Check the vendor advisory for mitigations.
References
- https://github.com/Neztore/save-server/security/advisories/GHSA-wwrj-35w6-77ff
- https://medium.com/cross-site-request-forgery-csrf/double-submit-cookie-pattern-65bb71d80d9f
- https://www.npmjs.com/package/save-server
- https://github.com/Neztore/save-server/security/advisories/GHSA-wwrj-35w6-77ff
- https://medium.com/cross-site-request-forgery-csrf/double-submit-cookie-pattern-65bb71d80d9f
- https://www.npmjs.com/package/save-server
Get alerted when CVE-2020-15135 or the next vulnerability affects your stack