What’s Vulnerable › Vulnerabilities

CVE-2020-15138: Cross-Site Scripting in Prism

Description

Prism is vulnerable to Cross-Site Scripting. The easing preview of the Previewers plugin has an XSS vulnerability that allows attackers to execute arbitrary code in Safari and Internet Explorer. This impacts all Safari and Internet Explorer users of Prism >=v1.1.0 that use the _Previewers_ plugin (>=v1.10.0) or the _Previewer: Easing_ plugin (v1.1.0 to v1.9.0). This problem is fixed in version 1.21.0. To workaround the issue without upgrading, disable the easing preview on all impacted code blocks. You need Prism v1.10.0 or newer to apply this workaround.

Affected products

How to fix

Upgrade to a fixed version: PrismJS Previewers 1.21.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2020-15138 or the next vulnerability affects your stack