What’s Vulnerable › Vulnerabilities
CVE-2020-15139: XSS in MyBB
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-08-10 · updated 2026-06-17
- Weakness: CWE-79
Description
In MyBB before version 1.8.24, the custom MyCode (BBCode) for the visual editor doesn't escape input properly when rendering HTML, resulting in a DOM-based XSS vulnerability. The weakness can be exploited by pointing a victim to a page where the visual editor is active (e.g. as a post or Private Message) and operates on a maliciously crafted MyCode message. This may occur on pages where message content is pre-filled using a GET/POST parameter, or on reply pages where a previously saved malicious message is quoted. After upgrading MyBB to 1.8.24, make sure to update the version attribute in the `codebuttons` template for non-default themes to serve the latest version of the patched `jscripts/bbcodes_sceditor.js` file.
Affected products
- mybb: before 1.8.24 — fixed in 1.8.24
How to fix
Upgrade to a fixed version: mybb 1.8.24. Check the vendor advisory for mitigations.
References
- https://github.com/mybb/mybb/commit/37ad29dcd25489a37bdd89ebac761f22492558b0
- https://github.com/mybb/mybb/security/advisories/GHSA-37h7-vfv6-f8rj
- https://mybb.com/versions/1.8.24/
- https://github.com/mybb/mybb/commit/37ad29dcd25489a37bdd89ebac761f22492558b0
- https://github.com/mybb/mybb/security/advisories/GHSA-37h7-vfv6-f8rj
- https://mybb.com/versions/1.8.24/
Get alerted when CVE-2020-15139 or the next vulnerability affects your stack