What’s Vulnerable › Vulnerabilities
CVE-2020-15142: Arbitrary Code Generation
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-08-14 · updated 2026-06-17
- Weakness: CWE-94
Description
In openapi-python-client before version 0.5.3, clients generated with a maliciously crafted OpenAPI Document can generate arbitrary Python code. Subsequent execution of this malicious client is arbitrary code execution.
Affected products
- triaxtec openapi-python-client: before 0.5.3 — fixed in 0.5.3
How to fix
Upgrade to a fixed version: triaxtec openapi-python-client 0.5.3. Check the vendor advisory for mitigations.
References
- https://github.com/triaxtec/openapi-python-client/blob/main/CHANGELOG.md#053---2020-08-13
- https://github.com/triaxtec/openapi-python-client/commit/f7a56aae32cba823a77a84a1f10400799b19c19a
- https://github.com/triaxtec/openapi-python-client/security/advisories/GHSA-9x4c-63pf-525f
- https://pypi.org/project/openapi-python-client/
- https://github.com/triaxtec/openapi-python-client/blob/main/CHANGELOG.md#053---2020-08-13
- https://github.com/triaxtec/openapi-python-client/commit/f7a56aae32cba823a77a84a1f10400799b19c19a
- https://github.com/triaxtec/openapi-python-client/security/advisories/GHSA-9x4c-63pf-525f
- https://pypi.org/project/openapi-python-client/
Get alerted when CVE-2020-15142 or the next vulnerability affects your stack