What’s Vulnerable › Vulnerabilities
CVE-2020-15143: Remote Code Execution in SyliusResourceBundle
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-08-20 · updated 2026-06-17
- Weakness: CWE-74
Description
In SyliusResourceBundle before versions 1.3.14, 1.4.7, 1.5.2 and 1.6.4, rrequest parameters injected inside an expression evaluated by `symfony/expression-language` package haven't been sanitized properly. This allows the attacker to access any public service by manipulating that request parameter, allowing for Remote Code Execution. This issue has been patched for versions 1.3.14, 1.4.7, 1.5.2 and 1.6.4. Versions prior to 1.3 were not patched.
Affected products
- SyliusResourceBundle: through 1.3.13; from 1.4.0 through 1.4.6; from 1.5.0 through 1.5.1; from 1.6.0 through 1.6.3
References
- https://github.com/Sylius/SyliusResourceBundle/security/advisories/GHSA-p4pj-9g59-4ppv
- https://github.com/Sylius/SyliusResourceBundle/security/advisories/GHSA-p4pj-9g59-4ppv
Get alerted when CVE-2020-15143 or the next vulnerability affects your stack