What’s Vulnerable › Vulnerabilities
CVE-2020-15148: Unsafe deserialization in Yii 2
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 77.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-09-15 · updated 2026-06-17
- Weakness: CWE-502
Description
Yii 2 (yiisoft/yii2) before version 2.0.38 is vulnerable to remote code execution if the application calls `unserialize()` on arbitrary user input. This is fixed in version 2.0.38. A possible workaround without upgrading is available in the linked advisory.
Affected products
- yiisoft yii: before 2.0.38 — fixed in 2.0.38
How to fix
Upgrade to a fixed version: yiisoft yii 2.0.38. Check the vendor advisory for mitigations.
References
- https://github.com/yiisoft/yii2/commit/9abccb96d7c5ddb569f92d1a748f50ee9b3e2b99
- https://github.com/yiisoft/yii2/security/advisories/GHSA-699q-wcff-g9mj
- https://github.com/yiisoft/yii2/commit/9abccb96d7c5ddb569f92d1a748f50ee9b3e2b99
- https://github.com/yiisoft/yii2/security/advisories/GHSA-699q-wcff-g9mj
Get alerted when CVE-2020-15148 or the next vulnerability affects your stack