What’s Vulnerable › Vulnerabilities
CVE-2020-15151: Observable Timing Discrepancy in OpenMage LTS
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-08-20 · updated 2026-06-17
- Weakness: CWE-203
Description
OpenMage LTS before versions 19.4.6 and 20.0.2 allows attackers to circumvent the `fromkey protection` in the Admin Interface and increases the attack surface for Cross Site Request Forgery attacks. This issue is related to Adobe's CVE-2020-9690. It is patched in versions 19.4.6 and 20.0.2.
Affected products
- Adobe Magento Commerce: through 2.3.5
- Openmage Long Term Support: before 19.4.6; from 20.0.0 before 20.0.2 — fixed in 19.4.6, 20.0.2
How to fix
Upgrade to a fixed version: Openmage Long Term Support 19.4.6, 20.0.2. Check the vendor advisory for mitigations.
References
- https://github.com/OpenMage/magento-lts/commit/7c526bc6a6a51b57a1bab4c60f104dc36cde347a
- https://github.com/OpenMage/magento-lts/security/advisories/GHSA-crf2-xm6x-46p6
- https://helpx.adobe.com/security/products/magento/apsb20-47.html
- https://github.com/OpenMage/magento-lts/commit/7c526bc6a6a51b57a1bab4c60f104dc36cde347a
- https://github.com/OpenMage/magento-lts/security/advisories/GHSA-crf2-xm6x-46p6
- https://helpx.adobe.com/security/products/magento/apsb20-47.html
Get alerted when CVE-2020-15151 or the next vulnerability affects your stack