What’s Vulnerable › Vulnerabilities
CVE-2020-15152: Server-Side Request Forgery in ftp-srv
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-08-17 · updated 2026-06-17
- Weakness: CWE-918
Description
ftp-srv is an npm package which is a modern and extensible FTP server designed to be simple yet configurable. In ftp-srv before versions 2.19.6, 3.1.2, and 4.3.4 are vulnerable to Server-Side Request Forgery. The PORT command allows arbitrary IPs which can be used to cause the server to make a connection elsewhere. A possible workaround is blocking the PORT through the configuration. This issue is fixed in version2 2.19.6, 3.1.2, and 4.3.4. More information can be found on the linked advisory.
Affected products
- autovance ftp-srv: before 2.19.6; from 3.0.0 before 3.1.2; from 4.0.0 before 4.3.4 — fixed in 2.19.6, 3.1.2, 4.3.4
How to fix
Upgrade to a fixed version: autovance ftp-srv 2.19.6, 3.1.2, 4.3.4. Check the vendor advisory for mitigations.
References
- https://github.com/autovance/ftp-srv/commit/e449e75219d918c400dec65b4b0759f60476abca
- https://github.com/autovance/ftp-srv/security/advisories/GHSA-jw37-5gqr-cf9j
- https://www.npmjs.com/package/ftp-srv
- https://github.com/autovance/ftp-srv/commit/e449e75219d918c400dec65b4b0759f60476abca
- https://github.com/autovance/ftp-srv/security/advisories/GHSA-jw37-5gqr-cf9j
- https://www.npmjs.com/package/ftp-srv
Get alerted when CVE-2020-15152 or the next vulnerability affects your stack