What’s Vulnerable › Vulnerabilities
CVE-2020-15153: Unauthenticated SQL injection in Ampache
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-30 · updated 2026-06-17
- Weakness: CWE-89
Description
Ampache before version 4.2.2 allows unauthenticated users to perform SQL injection. Refer to the referenced GitHub Security Advisory for details and a workaround. This is fixed in version 4.2.2 and the development branch.
Affected products
- ampache: before 4.2.2 — fixed in 4.2.2
How to fix
Upgrade to a fixed version: ampache 4.2.2. Check the vendor advisory for mitigations.
References
- https://github.com/ampache/ampache/commit/e92cb6154c32c513b9c07e5fdbf5ac7de81ef5ed
- https://github.com/ampache/ampache/releases/tag/4.2.2
- https://github.com/ampache/ampache/security/advisories/GHSA-phr3-mpx5-7826
- https://github.com/ampache/ampache/commit/e92cb6154c32c513b9c07e5fdbf5ac7de81ef5ed
- https://github.com/ampache/ampache/releases/tag/4.2.2
- https://github.com/ampache/ampache/security/advisories/GHSA-phr3-mpx5-7826
Get alerted when CVE-2020-15153 or the next vulnerability affects your stack