What’s Vulnerable › Vulnerabilities
CVE-2020-15156: XSS due to lack of CSRF validation for replying/publishing
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-08-26 · updated 2026-06-17
- Weakness: CWE-352
Description
In nodebb-plugin-blog-comments before version 0.7.0, a logged in user is vulnerable to an XSS attack which could allow a third party to post on their behalf on the forum. This is due to lack of CSRF validation.
Affected products
- psychobunny nodebb-plugin-blog-comments: before 0.7.0 — fixed in 0.7.0
How to fix
Upgrade to a fixed version: psychobunny nodebb-plugin-blog-comments 0.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/psychobunny/nodebb-plugin-blog-comments/commit/cf43beedb05131937ef46f365ab0a0c6fa6ac618
- https://github.com/psychobunny/nodebb-plugin-blog-comments/security/advisories/GHSA-43m5-c88r-cjvv
- https://www.npmjs.com/package/nodebb-plugin-blog-comments
- https://github.com/psychobunny/nodebb-plugin-blog-comments/commit/cf43beedb05131937ef46f365ab0a0c6fa6ac618
- https://github.com/psychobunny/nodebb-plugin-blog-comments/security/advisories/GHSA-43m5-c88r-cjvv
- https://www.npmjs.com/package/nodebb-plugin-blog-comments
Get alerted when CVE-2020-15156 or the next vulnerability affects your stack