What’s Vulnerable › Vulnerabilities
CVE-2020-15158: Heap buffer overflow in libIEC61850
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-08-26 · updated 2026-06-17
- Weakness: CWE-119
Description
In libIEC61850 before version 1.4.3, when a message with COTP message length field with value < 4 is received an integer underflow will happen leading to heap buffer overflow. This can cause an application crash or on some platforms even the execution of remote code. If your application is used in open networks or there are untrusted nodes in the network it is highly recommend to apply the patch. This was patched with commit 033ab5b. Users of version 1.4.x should upgrade to version 1.4.3 when available. As a workaround changes of commit 033ab5b can be applied to older versions.
Affected products
- mz-automation libiec61850: from 1.4.0 before 1.4.3 — fixed in 1.4.3
How to fix
Upgrade to a fixed version: mz-automation libiec61850 1.4.3. Check the vendor advisory for mitigations.
References
- https://github.com/mz-automation/libiec61850/commit/033ab5b6488250c8c3b838f25a7cbc3e099230bb
- https://github.com/mz-automation/libiec61850/issues/250
- https://github.com/mz-automation/libiec61850/security/advisories/GHSA-pq77-fmf7-hjw8
- https://github.com/mz-automation/libiec61850/commit/033ab5b6488250c8c3b838f25a7cbc3e099230bb
- https://github.com/mz-automation/libiec61850/issues/250
- https://github.com/mz-automation/libiec61850/security/advisories/GHSA-pq77-fmf7-hjw8
Get alerted when CVE-2020-15158 or the next vulnerability affects your stack