What’s Vulnerable › Vulnerabilities
CVE-2020-15161: Potential XSS in PrestaShop
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-09-24 · updated 2026-06-17
- Weakness: CWE-79
Description
In PrestaShop from version 1.6.0.4 and before version 1.7.6.8 an attacker is able to inject javascript while using the contact form. The problem is fixed in 1.7.6.8
Affected products
- PrestaShop: from 1.6.0.4 before 1.7.6.8 — fixed in 1.7.6.8
How to fix
Upgrade to a fixed version: PrestaShop 1.7.6.8. Check the vendor advisory for mitigations.
References
- https://github.com/PrestaShop/PrestaShop/commit/562a231fec18a928e4a601860416fe11af274672
- https://github.com/PrestaShop/PrestaShop/releases/tag/1.7.6.8
- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-5cp2-r794-w37w
- https://github.com/PrestaShop/PrestaShop/commit/562a231fec18a928e4a601860416fe11af274672
- https://github.com/PrestaShop/PrestaShop/releases/tag/1.7.6.8
- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-5cp2-r794-w37w
Get alerted when CVE-2020-15161 or the next vulnerability affects your stack