What’s Vulnerable › Vulnerabilities
CVE-2020-15171: Users with SCRIPT rights can execute arbitrary code in XWiki
- Severity: medium (CVSS 6.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-09-10 · updated 2026-06-17
- Weakness: CWE-94
Description
In XWiki before versions 11.10.5 or 12.2.1, any user with SCRIPT right (EDIT right before XWiki 7.4) can gain access to the application server Servlet context which contains tools allowing to instantiate arbitrary Java objects and invoke methods that may lead to arbitrary code execution. The only workaround is to give SCRIPT right only to trusted users.
Affected products
- xwiki-platform: before 11.10.5; from 12.0.0 before 12.2.1 — fixed in 11.10.5, 12.2.1
How to fix
Upgrade to a fixed version: xwiki-platform 11.10.5, 12.2.1. Check the vendor advisory for mitigations.
References
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-7qw5-pqhc-xm4g
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-7qw5-pqhc-xm4g
Get alerted when CVE-2020-15171 or the next vulnerability affects your stack