What’s Vulnerable › Vulnerabilities
CVE-2020-15177: Unauthenticated Stored XSS in GLPI
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-10-07 · updated 2026-06-17
- Weakness: CWE-79
Description
In GLPI before version 9.5.2, the `install/install.php` endpoint insecurely stores user input into the database as `url_base` and `url_base_api`. These settings are referenced throughout the application and allow for vulnerabilities like Cross-Site Scripting and Insecure Redirection Since authentication is not required to perform these changes,anyone could point these fields at malicious websites or form input in a way to trigger XSS. Leveraging JavaScript it's possible to steal cookies, perform actions as the user, etc. The issue is patched in version 9.5.2.
Affected products
- glpi-project glpi: before 9.5.2 — fixed in 9.5.2
How to fix
Upgrade to a fixed version: glpi-project glpi 9.5.2. Check the vendor advisory for mitigations.
References
- https://github.com/glpi-project/glpi/commit/a8109d4ee970a222faf48cf48fae2d2f06465796
- https://github.com/glpi-project/glpi/security/advisories/GHSA-prvh-9m4h-4m79
- https://github.com/glpi-project/glpi/commit/a8109d4ee970a222faf48cf48fae2d2f06465796
- https://github.com/glpi-project/glpi/security/advisories/GHSA-prvh-9m4h-4m79
Get alerted when CVE-2020-15177 or the next vulnerability affects your stack