What’s Vulnerable › Vulnerabilities
CVE-2020-15178: Potential XSS in PrestaShop contactform
- Severity: critical (CVSS 9.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-09-15 · updated 2026-06-17
- Weakness: CWE-79
Description
In PrestaShop contactform module (prestashop/contactform) before version 4.3.0, an attacker is able to inject JavaScript while using the contact form. The `message` field was incorrectly unescaped, possibly allowing attackers to execute arbitrary JavaScript in a victim's browser.
Affected products
- PrestaShop contactform: before 4.3.0 — fixed in 4.3.0
How to fix
Upgrade to a fixed version: PrestaShop contactform 4.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/PrestaShop/contactform/commit/ecd9f5d14920ec00885766a7cb41bcc5ed8bfa09
- https://github.com/PrestaShop/contactform/security/advisories/GHSA-95hx-62rh-gg96
- https://packagist.org/packages/prestashop/contactform
- https://github.com/PrestaShop/contactform/commit/ecd9f5d14920ec00885766a7cb41bcc5ed8bfa09
- https://github.com/PrestaShop/contactform/security/advisories/GHSA-95hx-62rh-gg96
- https://packagist.org/packages/prestashop/contactform
Get alerted when CVE-2020-15178 or the next vulnerability affects your stack