What’s Vulnerable › Vulnerabilities
CVE-2020-15187: Duplicate plugin entries in Helm
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-09-17 · updated 2026-06-17
- Weakness: CWE-74
Description
In Helm before versions 2.16.11 and 3.3.2, a Helm plugin can contain duplicates of the same entry, with the last one always used. If a plugin is compromised, this lowers the level of access that an attacker needs to modify a plugin's install hooks, causing a local execution attack. To perform this attack, an attacker must have write access to the git repository or plugin archive (.tgz) while being downloaded (which can occur during a MITM attack on a non-SSL connection). This issue has been patched in Helm 2.16.11 and Helm 3.3.2. As a possible workaround make sure to install plugins using a secure connection protocol like SSL.
Affected products
- helm: from 2.0.0 before 2.16.11; from 3.0.0 before 3.3.2 — fixed in 2.16.11, 3.3.2
How to fix
Upgrade to a fixed version: helm 2.16.11, 3.3.2. Check the vendor advisory for mitigations.
References
- https://github.com/helm/helm/commit/6aab63765f99050b115f0aec3d6350c85e8da946
- https://github.com/helm/helm/commit/ac7c07c37d87e09797f714fb57aa5e9cb99d9450
- https://github.com/helm/helm/commit/b0296c0522e837d65f944beefa3fb64fd08ac304
- https://github.com/helm/helm/commit/c8d6b01d72c9604e43ee70d0d78fadd54c2d8499
- https://github.com/helm/helm/commit/d9ef5ce8bad512e325390c0011be1244b8380e4b
- https://github.com/helm/helm/commit/f2ede29480b507b7d8bb152dd8b6b86248b00658
- https://github.com/helm/helm/security/advisories/GHSA-c52f-pq47-2r9j
- https://github.com/helm/helm/commit/d9ef5ce8bad512e325390c0011be1244b8380e4b
- https://github.com/helm/helm/security/advisories/GHSA-c52f-pq47-2r9j
Get alerted when CVE-2020-15187 or the next vulnerability affects your stack