What’s Vulnerable › Vulnerabilities
CVE-2020-15190: Segfault in Tensorflow
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-09-25 · updated 2026-06-17
- Weakness: CWE-20
Description
In Tensorflow before versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1, the `tf.raw_ops.Switch` operation takes as input a tensor and a boolean and outputs two tensors. Depending on the boolean value, one of the tensors is exactly the input tensor whereas the other one should be an empty tensor. However, the eager runtime traverses all tensors in the output. Since only one of the tensors is defined, the other one is `nullptr`, hence we are binding a reference to `nullptr`. This is undefined behavior and reported as an error if compiling with `-fsanitize=null`. In this case, this results in a segmentation fault The issue is patched in commit da8558533d925694483d2c136a9220d6d49d843c, and is released in TensorFlow versions 1.15.4, 2.0.3, 2.1.2, 2.2.1, or 2.3.1.
Affected products
- tensorflow: before 1.15.4; from 2.0.0 before 2.0.3; from 2.1.0 before 2.1.2; from 2.2.0 before 2.2.1; from 2.3.0 before 2.3.1 — fixed in 1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1
- openSUSE Leap: 15.2
How to fix
Upgrade to a fixed version: tensorflow 1.15.4, 2.0.3, 2.1.2, 2.2.1. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00065.html
- https://github.com/tensorflow/tensorflow/commit/da8558533d925694483d2c136a9220d6d49d843c
- https://github.com/tensorflow/tensorflow/releases/tag/v2.3.1
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-4g9f-63rx-5cw4
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00065.html
- https://github.com/tensorflow/tensorflow/commit/da8558533d925694483d2c136a9220d6d49d843c
- https://github.com/tensorflow/tensorflow/releases/tag/v2.3.1
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-4g9f-63rx-5cw4
Get alerted when CVE-2020-15190 or the next vulnerability affects your stack