What’s Vulnerable › Vulnerabilities
CVE-2020-15203: Denial of Service in Tensorflow
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-09-25 · updated 2026-06-17
- Weakness: CWE-20
Description
In Tensorflow before versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1, by controlling the `fill` argument of tf.strings.as_string, a malicious attacker is able to trigger a format string vulnerability due to the way the internal format use in a `printf` call is constructed. This may result in segmentation fault. The issue is patched in commit 33be22c65d86256e6826666662e40dbdfe70ee83, and is released in TensorFlow versions 1.15.4, 2.0.3, 2.1.2, 2.2.1, or 2.3.1.
Affected products
- tensorflow: before 1.15.4; from 2.0.0 before 2.0.3; from 2.1.0 before 2.1.2; from 2.2.0 before 2.2.1; from 2.3.0 before 2.3.1 — fixed in 1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1
- openSUSE Leap: 15.2
How to fix
Upgrade to a fixed version: tensorflow 1.15.4, 2.0.3, 2.1.2, 2.2.1. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00065.html
- https://github.com/tensorflow/tensorflow/commit/33be22c65d86256e6826666662e40dbdfe70ee83
- https://github.com/tensorflow/tensorflow/releases/tag/v2.3.1
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-xmq7-7fxm-rr79
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00065.html
- https://github.com/tensorflow/tensorflow/commit/33be22c65d86256e6826666662e40dbdfe70ee83
- https://github.com/tensorflow/tensorflow/releases/tag/v2.3.1
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-xmq7-7fxm-rr79
Get alerted when CVE-2020-15203 or the next vulnerability affects your stack