What’s Vulnerable › Vulnerabilities
CVE-2020-15209: Null pointer dereference in tensorflow-lite
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-09-25 · updated 2026-06-17
- Weakness: CWE-476
Description
In tensorflow-lite before versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1, a crafted TFLite model can force a node to have as input a tensor backed by a `nullptr` buffer. This can be achieved by changing a buffer index in the flatbuffer serialization to convert a read-only tensor to a read-write one. The runtime assumes that these buffers are written to before a possible read, hence they are initialized with `nullptr`. However, by changing the buffer index for a tensor and implicitly converting that tensor to be a read-write one, as there is nothing in the model that writes to it, we get a null pointer dereference. The issue is patched in commit 0b5662bc, and is released in TensorFlow versions 1.15.4, 2.0.3, 2.1.2, 2.2.1, or 2.3.1.
Affected products
- tensorflow: before 1.15.4; from 2.0.0 before 2.0.3; from 2.1.0 before 2.1.2; from 2.2.0 before 2.2.1; from 2.3.0 before 2.3.1 — fixed in 1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1
- openSUSE Leap: 15.2
How to fix
Upgrade to a fixed version: tensorflow 1.15.4, 2.0.3, 2.1.2, 2.2.1. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00065.html
- https://github.com/tensorflow/tensorflow/commit/0b5662bc2be13a8c8f044d925d87fb6e56247cd8
- https://github.com/tensorflow/tensorflow/releases/tag/v2.3.1
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-qh32-6jjc-qprm
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00065.html
- https://github.com/tensorflow/tensorflow/commit/0b5662bc2be13a8c8f044d925d87fb6e56247cd8
- https://github.com/tensorflow/tensorflow/releases/tag/v2.3.1
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-qh32-6jjc-qprm
Get alerted when CVE-2020-15209 or the next vulnerability affects your stack