What’s Vulnerable › Vulnerabilities

CVE-2020-15210: Segmentation fault in tensorflow-lite

Description

In tensorflow-lite before versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1, if a TFLite saved model uses the same tensor as both input and output of an operator, then, depending on the operator, we can observe a segmentation fault or just memory corruption. We have patched the issue in d58c96946b and will release patch releases for all versions between 1.15 and 2.3. We recommend users to upgrade to TensorFlow 1.15.4, 2.0.3, 2.1.2, 2.2.1, or 2.3.1.

Affected products

How to fix

Upgrade to a fixed version: tensorflow 1.15.4, 2.0.3, 2.1.2, 2.2.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2020-15210 or the next vulnerability affects your stack