What’s Vulnerable › Vulnerabilities
CVE-2020-15226: SQL Injection in GLPI Search API
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-10-07 · updated 2026-06-17
- Weakness: CWE-89
Description
In GLPI before version 9.5.2, there is a SQL Injection in the API's search function. Not only is it possible to break the SQL syntax, but it is also possible to utilise a UNION SELECT query to reflect sensitive information such as the current database version, or database user. The most likely scenario for this vulnerability is with someone who has an API account to the system. The issue is patched in version 9.5.2. A proof-of-concept with technical details is available in the linked advisory.
Affected products
- glpi-project glpi: before 9.5.2 — fixed in 9.5.2
How to fix
Upgrade to a fixed version: glpi-project glpi 9.5.2. Check the vendor advisory for mitigations.
References
- https://github.com/glpi-project/glpi/commit/3dc4475c56b241ad659cc5c7cb5fb65727409cf0
- https://github.com/glpi-project/glpi/security/advisories/GHSA-jwpv-7m4h-5gvc
- https://github.com/glpi-project/glpi/commit/3dc4475c56b241ad659cc5c7cb5fb65727409cf0
- https://github.com/glpi-project/glpi/security/advisories/GHSA-jwpv-7m4h-5gvc
Get alerted when CVE-2020-15226 or the next vulnerability affects your stack