What’s Vulnerable › Vulnerabilities
CVE-2020-15231: Cross-site scripting attack in mapfish-print
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-10-02 · updated 2026-06-17
- Weakness: CWE-79
Description
In mapfish-print before version 3.24, a user can use the JSONP support to do a Cross-site scripting.
Affected products
- mapfish-print: before 3.24 — fixed in 3.24
How to fix
Upgrade to a fixed version: mapfish-print 3.24. Check the vendor advisory for mitigations.
References
- https://github.com/mapfish/mapfish-print/pull/1397/commits/89155f2506b9cee822e15ce60ccae390a1419d5e
- https://github.com/mapfish/mapfish-print/security/advisories/GHSA-w534-q4xf-h5v2
- https://github.com/mapfish/mapfish-print/pull/1397/commits/89155f2506b9cee822e15ce60ccae390a1419d5e
- https://github.com/mapfish/mapfish-print/security/advisories/GHSA-w534-q4xf-h5v2
Get alerted when CVE-2020-15231 or the next vulnerability affects your stack