What’s Vulnerable › Vulnerabilities
CVE-2020-15238: Local privilege escalation Blueman
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-10-27 · updated 2026-06-17
- Weakness: CWE-74
Description
Blueman is a GTK+ Bluetooth Manager. In Blueman before 2.1.4, the DhcpClient method of the D-Bus interface to blueman-mechanism is prone to an argument injection vulnerability. The impact highly depends on the system configuration. If Polkit-1 is disabled and for versions lower than 2.0.6, any local user can possibly exploit this. If Polkit-1 is enabled for version 2.0.6 and later, a possible attacker needs to be allowed to use the `org.blueman.dhcp.client` action. That is limited to users in the wheel group in the shipped rules file that do have the privileges anyway. On systems with ISC DHCP client (dhclient), attackers can pass arguments to `ip link` with the interface name that can e.g. be used to bring down an interface or add an arbitrary XDP/BPF program. On systems with dhcpcd and without ISC DHCP client, attackers can even run arbitrary scripts by passing `-c/path/to/script` as an interface name. Patches are included in 2.1.4 and master that change the DhcpClient D-Bus method(s) to accept BlueZ network object paths instead of network interface names. A backport to 2.0(.8) is also available. As a workaround, make sure that Polkit-1-support is enabled and limit privileges for the `org.blueman.dhcp.client` action to users that are able to run arbitrary commands as root anyway in /usr/share/polkit-1/rules.d/blueman.rules.
Affected products
- Blueman Project Blueman: before 2.1.4 — fixed in 2.1.4
- Debian Linux: 9.0, 10.0
- Fedoraproject Fedora: 31, 32, 33
How to fix
Upgrade to a fixed version: Blueman Project Blueman 2.1.4. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/159740/Blueman-Local-Root-Privilege-Escalation.html
- https://bugs.launchpad.net/ubuntu/+source/blueman/+bug/1897287
- https://github.com/blueman-project/blueman/releases/tag/2.1.4
- https://github.com/blueman-project/blueman/security/advisories/GHSA-jpc9-mgw6-2xwx
- https://lists.debian.org/debian-lts-announce/2020/11/msg00005.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/3F4EQU6CAPBKAPJ42HTB473NJLXFKB32/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6CFLMNHAHX5HPIKC5IG6F25HO5Z6RH2N/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/W52NP7HRFTNAVNZLGKY4GR3JIZG5KKGS/
- https://security.gentoo.org/glsa/202011-11
- https://www.debian.org/security/2020/dsa-4781
- http://packetstormsecurity.com/files/159740/Blueman-Local-Root-Privilege-Escalation.html
- https://bugs.launchpad.net/ubuntu/+source/blueman/+bug/1897287
Get alerted when CVE-2020-15238 or the next vulnerability affects your stack