What’s Vulnerable › Vulnerabilities
CVE-2020-15240: Regression in JWT Signature Validation
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-10-21 · updated 2026-06-17
- Weakness: CWE-287
Description
omniauth-auth0 (rubygems) versions >= 2.3.0 and < 2.4.1 improperly validate the JWT token signature when using the `jwt_validator.verify` method. Improper validation of the JWT token signature can allow an attacker to bypass authentication and authorization. You are affected by this vulnerability if all of the following conditions apply: 1. You are using `omniauth-auth0`. 2. You are using `JWTValidator.verify` method directly OR you are not authenticating using the SDK’s default Authorization Code Flow. The issue is patched in version 2.4.1.
Affected products
- auth0 omniauth-auth0: from 2.3.0 before 2.4.1 — fixed in 2.4.1
How to fix
Upgrade to a fixed version: auth0 omniauth-auth0 2.4.1. Check the vendor advisory for mitigations.
References
- https://github.com/auth0/omniauth-auth0/commit/fd3a14f4ccdfbc515d1121d6378ff88bf55a7a7a
- https://github.com/auth0/omniauth-auth0/security/advisories/GHSA-58r4-h6v8-jcvm
- https://rubygems.org/gems/omniauth-auth0
- https://github.com/auth0/omniauth-auth0/commit/fd3a14f4ccdfbc515d1121d6378ff88bf55a7a7a
- https://github.com/auth0/omniauth-auth0/security/advisories/GHSA-58r4-h6v8-jcvm
- https://rubygems.org/gems/omniauth-auth0
Get alerted when CVE-2020-15240 or the next vulnerability affects your stack