What’s Vulnerable › Vulnerabilities

CVE-2020-15241: Cross-Site Scripting in TYPO3 Fluid Engine

Description

TYPO3 Fluid Engine (package `typo3fluid/fluid`) before versions 2.0.5, 2.1.4, 2.2.1, 2.3.5, 2.4.1, 2.5.5 or 2.6.1 is vulnerable to cross-site scripting when making use of the ternary conditional operator in templates like `{showFullName ? fullName : defaultValue}`. Updated versions of this package are bundled in following TYPO3 (`typo3/cms-core`) versions as well: TYPO3 v8.7.25 (using `typo3fluid/fluid` v2.5.4) and TYPO3 v9.5.6 (using `typo3fluid/fluid` v2.6.1).

Affected products

How to fix

Upgrade to a fixed version: TYPO3 Fluid Engine 2.0.5, 2.1.4, 2.2.1, 2.3.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2020-15241 or the next vulnerability affects your stack