What’s Vulnerable › Vulnerabilities
CVE-2020-15271: Shell Command Execution in lookatme
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-10-26 · updated 2026-06-17
- Weakness: CWE-78
Description
In lookatme (python/pypi package) versions prior to 2.3.0, the package automatically loaded the built-in "terminal" and "file_loader" extensions. Users that use lookatme to render untrusted markdown may have malicious shell commands automatically run on their system. This is fixed in version 2.3.0. As a workaround, the `lookatme/contrib/terminal.py` and `lookatme/contrib/file_loader.py` files may be manually deleted. Additionally, it is always recommended to be aware of what is being rendered with lookatme.
Affected products
- d0c-s4vage lookatme: before 2.3.0 — fixed in 2.3.0
How to fix
Upgrade to a fixed version: d0c-s4vage lookatme 2.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/d0c-s4vage/lookatme/commit/72fe36b784b234548d49dae60b840c37f0eb8d84
- https://github.com/d0c-s4vage/lookatme/pull/110
- https://github.com/d0c-s4vage/lookatme/releases/tag/v2.3.0
- https://github.com/d0c-s4vage/lookatme/security/advisories/GHSA-c84h-w6cr-5v8q
- https://pypi.org/project/lookatme/#history
- https://github.com/d0c-s4vage/lookatme/commit/72fe36b784b234548d49dae60b840c37f0eb8d84
- https://github.com/d0c-s4vage/lookatme/pull/110
- https://github.com/d0c-s4vage/lookatme/releases/tag/v2.3.0
- https://github.com/d0c-s4vage/lookatme/security/advisories/GHSA-c84h-w6cr-5v8q
- https://pypi.org/project/lookatme/#history
Get alerted when CVE-2020-15271 or the next vulnerability affects your stack