What’s Vulnerable › Vulnerabilities
CVE-2020-15273: Cross-Site Scripting in baserCMS
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-10-30 · updated 2026-06-17
- Weakness: CWE-79
Description
baserCMS before version 4.4.1 is vulnerable to Cross-Site Scripting. The issue affects the following components: Edit feed settings, Edit widget area, Sub site new registration, New category registration. Arbitrary JavaScript may be executed by entering specific characters in the account that can access the file upload function category list, subsite setting list, widget area edit, and feed list on the management screen. The issue was introduced in version 4.0.0. It is fixed in version 4.4.1.
Affected products
- baserproject basercms: from 4.0.0 before 4.4.1 — fixed in 4.4.1
How to fix
Upgrade to a fixed version: baserproject basercms 4.4.1. Check the vendor advisory for mitigations.
References
- https://github.com/baserproject/basercms/commit/b70474ef9dcee6ad8826360884625dc7ca9041a1
- https://github.com/baserproject/basercms/security/advisories/GHSA-wpww-4jf4-4hx8
- https://packagist.org/packages/baserproject/basercms
- https://github.com/baserproject/basercms/commit/b70474ef9dcee6ad8826360884625dc7ca9041a1
- https://github.com/baserproject/basercms/security/advisories/GHSA-wpww-4jf4-4hx8
- https://packagist.org/packages/baserproject/basercms
Get alerted when CVE-2020-15273 or the next vulnerability affects your stack