What’s Vulnerable › Vulnerabilities
CVE-2020-15276: Cross Site Scripting in baserCMS
- Severity: high (CVSS 8.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-10-30 · updated 2026-06-17
- Weakness: CWE-79
Description
baserCMS before version 4.4.1 is vulnerable to Cross-Site Scripting. Arbitrary JavaScript may be executed by entering a crafted nickname in blog comments. The issue affects the blog comment component. It is fixed in version 4.4.1.
Affected products
- baserproject basercms: from 4.0.0 before 4.4.1 — fixed in 4.4.1
How to fix
Upgrade to a fixed version: baserproject basercms 4.4.1. Check the vendor advisory for mitigations.
References
- https://basercms.net/security/20201029
- https://github.com/baserproject/basercms/commit/d14f506385f21d67d5ff3462f204d4c2321b7c54
- https://github.com/baserproject/basercms/security/advisories/GHSA-fw5q-j9p4-3vxg
- https://basercms.net/security/20201029
- https://github.com/baserproject/basercms/commit/d14f506385f21d67d5ff3462f204d4c2321b7c54
- https://github.com/baserproject/basercms/security/advisories/GHSA-fw5q-j9p4-3vxg
Get alerted when CVE-2020-15276 or the next vulnerability affects your stack