What’s Vulnerable › Vulnerabilities
CVE-2020-15309
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-08-21 · updated 2026-06-17
- Weakness: CWE-362
Description
An issue was discovered in wolfSSL before 4.5.0, when single precision is not employed. Local attackers can conduct a cache-timing attack against public key operations. These attackers may already have obtained sensitive information if the affected system has been used for private key operations (e.g., signing with a private key).
Affected products
- wolfSSL: before 4.5.0 — fixed in 4.5.0
How to fix
Upgrade to a fixed version: wolfSSL 4.5.0. Check the vendor advisory for mitigations.
References
- https://arxiv.org/abs/2008.12188
- https://github.com/wolfSSL/wolfssl/releases/tag/v4.5.0-stable
- https://arxiv.org/abs/2008.12188
- https://github.com/wolfSSL/wolfssl/releases/tag/v4.5.0-stable
Get alerted when CVE-2020-15309 or the next vulnerability affects your stack