What’s Vulnerable › Vulnerabilities
CVE-2020-15387
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-09 · updated 2026-06-17
- Weakness: CWE-326
Description
The host SSH servers of Brocade Fabric OS before Brocade Fabric OS v7.4.2h, v8.2.1c, v8.2.2, v9.0.0, and Brocade SANnav before v2.1.1 utilize keys of less than 2048 bits, which may be vulnerable to man-in-the-middle attacks and/or insecure SSH communications.
Affected products
- Brocade SANnav: before 2.1.1 — fixed in 2.1.1
- Brocade Fabric OS: before 7.4.2; from 8.2.0 before 8.2.1; 7.4.2, 7.4.2a, 7.4.2b, 7.4.2c, 7.4.2d, 7.4.2f (+4) — fixed in 7.4.2, 8.2.1
How to fix
Upgrade to a fixed version: Brocade SANnav 2.1.1; Brocade Fabric OS 7.4.2, 8.2.1. Check the vendor advisory for mitigations.
References
- https://www.broadcom.com/support/fibre-channel-networking/security-advisories/brocade-security-advisory-2021-1291
- https://www.broadcom.com/support/fibre-channel-networking/security-advisories/brocade-security-advisory-2021-1291
Get alerted when CVE-2020-15387 or the next vulnerability affects your stack