What’s Vulnerable › Vulnerabilities
CVE-2020-15437
- Severity: medium (CVSS 4.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-11-23 · updated 2026-06-17
- Weakness: CWE-476
Description
The Linux kernel before version 5.8 is vulnerable to a NULL pointer dereference in drivers/tty/serial/8250/8250_core.c:serial8250_isa_init_ports() that allows local users to cause a denial of service by using the p->serial_in pointer which uninitialized.
Affected products
- Linux kernel: before 5.8 — fixed in 5.8
How to fix
Upgrade to a fixed version: Linux kernel 5.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2020-15437 or the next vulnerability affects your stack