What’s Vulnerable › Vulnerabilities
CVE-2020-15634
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-08-20 · updated 2026-06-17
- Weakness: CWE-134
Description
This vulnerability allows network-adjacent attackers to execute arbitrary code on affected installations of NETGEAR R6700 routers with firmware 1.0.4.84_10.0.58. Authentication is not required to exploit this vulnerability. The specific flaw exists within the handling of string table file uploads. The issue results from the lack of proper validation of a user-supplied string before using it as a format specifier. An attacker can leverage this vulnerability to execute code in the context of the web server. Was ZDI-CAN-9755.
Affected products
- NETGEAR R6700: before 1.0.4.98 — fixed in 1.0.4.98
How to fix
Upgrade to a fixed version: NETGEAR R6700 1.0.4.98. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000062126/Security-Advisory-for-Pre-Authentication-Command-Injection-on-R6700v3-PSV-2020-0189
- https://www.zerodayinitiative.com/advisories/ZDI-20-935/
- https://kb.netgear.com/000062126/Security-Advisory-for-Pre-Authentication-Command-Injection-on-R6700v3-PSV-2020-0189
- https://www.zerodayinitiative.com/advisories/ZDI-20-935/
Get alerted when CVE-2020-15634 or the next vulnerability affects your stack