What’s Vulnerable › Vulnerabilities
CVE-2020-15636
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-08-20 · updated 2026-06-17
- Weakness: CWE-121
Description
This vulnerability allows remote attackers to execute arbitrary code on affected installations of NETGEAR R6400, R6700, R7000, R7850, R7900, R8000, RS400, and XR300 routers with firmware 1.0.4.84_10.0.58. Authentication is not required to exploit this vulnerability. The specific flaw exists within the check_ra service. A crafted raePolicyVersion in a RAE_Policy.json file can trigger an overflow of a fixed-length stack-based buffer. An attacker can leverage this vulnerability to execute code in the context of root. Was ZDI-CAN-9852.
Affected products
- NETGEAR R6700: before 1.0.4.98 — fixed in 1.0.4.98
How to fix
Upgrade to a fixed version: NETGEAR R6700 1.0.4.98. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000062128/Security-Advisory-for-Pre-Authentication-Stack-Overflow-on-R6700v3-PSV-2020-0224
- https://www.zerodayinitiative.com/advisories/ZDI-20-937/
- https://kb.netgear.com/000062128/Security-Advisory-for-Pre-Authentication-Stack-Overflow-on-R6700v3-PSV-2020-0224
- https://www.zerodayinitiative.com/advisories/ZDI-20-937/
Get alerted when CVE-2020-15636 or the next vulnerability affects your stack