What’s Vulnerable › Vulnerabilities
CVE-2020-15641
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-08-25 · updated 2026-06-17
- Weakness: CWE-22
Description
This vulnerability allows remote attackers to disclose sensitive information on affected installations of Marvell QConvergeConsole 5.5.0.64. Authentication is not required to exploit this vulnerability. The specific flaw exists within the getFileUploadBytes method of the FlashValidatorServiceImpl class. The issue results from the lack of proper validation of a user-supplied path prior to using it in file operations. An attacker can leverage this vulnerability to disclose stored credentials, leading to further compromise. Was ZDI-CAN-10499.
Affected products
- Marvell QConvergeConsole: before 5.5.00.73 — fixed in 5.5.00.73
How to fix
Upgrade to a fixed version: Marvell QConvergeConsole 5.5.00.73. Check the vendor advisory for mitigations.
References
- https://www.marvell.com/content/dam/marvell/en/public-collateral/fibre-channel/marvell-fibre-channel-security-advisory-2020-07.pdf
- https://www.zerodayinitiative.com/advisories/ZDI-20-969/
- https://www.marvell.com/content/dam/marvell/en/public-collateral/fibre-channel/marvell-fibre-channel-security-advisory-2020-07.pdf
- https://www.zerodayinitiative.com/advisories/ZDI-20-969/
Get alerted when CVE-2020-15641 or the next vulnerability affects your stack