What’s Vulnerable › Vulnerabilities
CVE-2020-15642
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-08-25 · updated 2026-06-17
- Weakness: CWE-77
Description
This vulnerability allows remote attackers to execute arbitrary code on affected installations of installations of Marvell QConvergeConsole 5.5.0.64. Although authentication is required to exploit this vulnerability, the existing authentication mechanism can be bypassed. The specific flaw exists within the isHPSmartComponent method of the GWTTestServiceImpl class. The issue results from the lack of proper validation of a user-supplied string before using it to execute a system call. An attacker can leverage this vulnerability to execute code in the context of SYSTEM. Was ZDI-CAN-10501.
Affected products
- Marvell QConvergeConsole: before 5.5.00.73 — fixed in 5.5.00.73
How to fix
Upgrade to a fixed version: Marvell QConvergeConsole 5.5.00.73. Check the vendor advisory for mitigations.
References
- https://www.marvell.com/content/dam/marvell/en/public-collateral/fibre-channel/marvell-fibre-channel-security-advisory-2020-07.pdf
- https://www.zerodayinitiative.com/advisories/ZDI-20-970/
- https://www.marvell.com/content/dam/marvell/en/public-collateral/fibre-channel/marvell-fibre-channel-security-advisory-2020-07.pdf
- https://www.zerodayinitiative.com/advisories/ZDI-20-970/
Get alerted when CVE-2020-15642 or the next vulnerability affects your stack