What’s Vulnerable › Vulnerabilities
CVE-2020-15678
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-10-01 · updated 2026-06-17
- Weakness: CWE-416
Description
When recursing through graphical layers while scrolling, an iterator may have become invalid, resulting in a potential use-after-free. This occurs because the function APZCTreeManager::ComputeClippedCompositionBounds did not follow iterator invalidation rules. This vulnerability affects Firefox < 81, Thunderbird < 78.3, and Firefox ESR < 78.3.
Affected products
- Debian Linux: 9.0, 10.0
- Mozilla Firefox: before 81.0 — fixed in 81.0
- Mozilla Firefox ESR: before 78.3 — fixed in 78.3
- Mozilla Thunderbird: before 78.3 — fixed in 78.3
- openSUSE Leap: 15.1, 15.2
How to fix
Upgrade to a fixed version: Mozilla Firefox 81.0; Mozilla Firefox ESR 78.3; Mozilla Thunderbird 78.3. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00074.html
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00077.html
- https://bugzilla.mozilla.org/show_bug.cgi?id=1660211
- https://lists.debian.org/debian-lts-announce/2020/10/msg00020.html
- https://security.gentoo.org/glsa/202010-02
- https://www.debian.org/security/2020/dsa-4770
- https://www.mozilla.org/security/advisories/mfsa2020-42/
- https://www.mozilla.org/security/advisories/mfsa2020-43/
- https://www.mozilla.org/security/advisories/mfsa2020-44/
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00074.html
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00077.html
- https://bugzilla.mozilla.org/show_bug.cgi?id=1660211
Get alerted when CVE-2020-15678 or the next vulnerability affects your stack