What’s Vulnerable › Vulnerabilities
CVE-2020-15689
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-07-13 · updated 2026-06-17
- Weakness: CWE-476
Description
Appweb before 7.2.2 and 8.x before 8.1.0, when built with CGI support, mishandles an HTTP request with a Range header that lacks an exact range. This may result in a NULL pointer dereference and cause a denial of service.
Affected products
- EmbedThis Appweb: before 7.2.2; from 8.0.0 before 8.1.0 — fixed in 7.2.2, 8.1.0
How to fix
Upgrade to a fixed version: EmbedThis Appweb 7.2.2, 8.1.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2020-15689 or the next vulnerability affects your stack