What’s Vulnerable › Vulnerabilities
CVE-2020-15720
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-07-14 · updated 2026-06-17
- Weakness: CWE-295
Description
In Dogtag PKI through 10.8.3, the pki.client.PKIConnection class did not enable python-requests certificate validation. Since the verify parameter was hard-coded in all request functions, it was not possible to override the setting. As a result, tools making use of this class, such as the pki-server command, may have been vulnerable to Person-in-the-Middle attacks in certain non-localhost use cases. This is fixed in 10.9.0-b1.
Affected products
- Dogtag PKI: through 10.8.3
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1855273
- https://github.com/dogtagpki/pki/commit/50c23ec146ee9abf28c9de87a5f7787d495f0b72
- https://github.com/dogtagpki/pki/compare/v10.9.0-a2...v10.9.0-b1
- https://bugzilla.redhat.com/show_bug.cgi?id=1855273
- https://github.com/dogtagpki/pki/commit/50c23ec146ee9abf28c9de87a5f7787d495f0b72
- https://github.com/dogtagpki/pki/compare/v10.9.0-a2...v10.9.0-b1
Get alerted when CVE-2020-15720 or the next vulnerability affects your stack