What’s Vulnerable › Vulnerabilities
CVE-2020-15780
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-07-15 · updated 2026-06-17
- Weakness: CWE-862
Description
An issue was discovered in drivers/acpi/acpi_configfs.c in the Linux kernel before 5.7.7. Injection of malicious ACPI tables via configfs could be used by attackers to bypass lockdown and secure boot restrictions, aka CID-75b0cea7bf30.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 20.04
- Linux kernel: before 5.7.7 — fixed in 5.7.7
- openSUSE Leap: 15.1, 15.2
How to fix
Upgrade to a fixed version: Linux kernel 5.7.7. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00009.html
- http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00047.html
- http://www.openwall.com/lists/oss-security/2020/07/20/7
- http://www.openwall.com/lists/oss-security/2020/07/29/3
- http://www.openwall.com/lists/oss-security/2020/07/30/2
- http://www.openwall.com/lists/oss-security/2020/07/30/3
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.7.7
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=75b0cea7bf307f362057cc778efe89af4c615354
- https://git.zx2c4.com/american-unsigned-language/tree/american-unsigned-language-2.sh
- https://usn.ubuntu.com/4425-1/
- https://usn.ubuntu.com/4426-1/
- https://usn.ubuntu.com/4439-1/
Get alerted when CVE-2020-15780 or the next vulnerability affects your stack