What’s Vulnerable › Vulnerabilities
CVE-2020-15838
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-10-09 · updated 2026-06-17
- Weakness: CWE-732
Description
The Agent Update System in ConnectWise Automate before 2020.8 allows Privilege Escalation because the _LTUPDATE folder has weak permissions.
Affected products
- ConnectWise Automate: before 2020.8 — fixed in 2020.8
How to fix
Upgrade to a fixed version: ConnectWise Automate 2020.8. Check the vendor advisory for mitigations.
References
- https://dbeta.com/2020/10/05/PrivilegeEscalationInAutomateAgent
- https://www.connectwise.com/company/trust/security-bulletins
- https://dbeta.com/2020/10/05/PrivilegeEscalationInAutomateAgent
- https://www.connectwise.com/company/trust/security-bulletins
Get alerted when CVE-2020-15838 or the next vulnerability affects your stack