What’s Vulnerable › Vulnerabilities
CVE-2020-15862
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-08-20 · updated 2026-06-17
- Weakness: CWE-269
Description
Net-SNMP through 5.8 has Improper Privilege Management because SNMP WRITE access to the EXTEND MIB provides the ability to run arbitrary commands as root.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 18.04, 20.04
- net-snmp: before 5.8.1 — fixed in 5.8.1
- NetApp Cloud Backup: all versions
- NetApp Hci Management Node: all versions
- NetApp Smi-S Provider: all versions
- NetApp Solidfire: all versions
How to fix
Upgrade to a fixed version: net-snmp 5.8.1. Check the vendor advisory for mitigations.
References
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=965166
- https://github.com/net-snmp/net-snmp/commit/77f6c60f57dba0aaea5d8ef1dd94bcd0c8e6d205
- https://salsa.debian.org/debian/net-snmp/-/commit/fad8725402752746daf0a751dcff19eb6aeab52e
- https://security-tracker.debian.org/tracker/CVE-2020-15862
- https://security.gentoo.org/glsa/202008-12
- https://security.netapp.com/advisory/ntap-20200904-0001/
- https://usn.ubuntu.com/4471-1/
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=965166
- https://github.com/net-snmp/net-snmp/commit/77f6c60f57dba0aaea5d8ef1dd94bcd0c8e6d205
- https://salsa.debian.org/debian/net-snmp/-/commit/fad8725402752746daf0a751dcff19eb6aeab52e
- https://security-tracker.debian.org/tracker/CVE-2020-15862
- https://security.gentoo.org/glsa/202008-12
Get alerted when CVE-2020-15862 or the next vulnerability affects your stack