What’s Vulnerable › Vulnerabilities
CVE-2020-15877
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-07-21 · updated 2026-06-17
Description
An issue was discovered in LibreNMS before 1.65.1. It has insufficient access control for normal users because of "'guard' => 'admin'" instead of "'middleware' => ['can:admin']" in routes/web.php.
Affected products
- librenms: before 1.65.1 — fixed in 1.65.1
How to fix
Upgrade to a fixed version: librenms 1.65.1. Check the vendor advisory for mitigations.
References
- https://community.librenms.org/c/announcements
- https://github.com/librenms/librenms/commit/e5bb6d80bc308fc56b9a01ffb76c34159995353c
- https://github.com/librenms/librenms/compare/1.65...1.65.1
- https://github.com/librenms/librenms/pull/11915
- https://github.com/librenms/librenms/releases/tag/1.65.1
- https://shielder.it/blog
- https://community.librenms.org/c/announcements
- https://github.com/librenms/librenms/commit/e5bb6d80bc308fc56b9a01ffb76c34159995353c
- https://github.com/librenms/librenms/compare/1.65...1.65.1
- https://github.com/librenms/librenms/pull/11915
- https://github.com/librenms/librenms/releases/tag/1.65.1
- https://shielder.it/blog
Get alerted when CVE-2020-15877 or the next vulnerability affects your stack