What’s Vulnerable › Vulnerabilities
CVE-2020-15885
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-07-23 · updated 2026-06-17
- Weakness: CWE-79
Description
A Cross-Site Scripting (XSS) vulnerability in the comment module before 4.0 for MunkiReport allows remote attackers to inject arbitrary web script or HTML by posting a new comment.
Affected products
- Munkireport Project Comment: before 4.0 — fixed in 4.0
How to fix
Upgrade to a fixed version: Munkireport Project Comment 4.0. Check the vendor advisory for mitigations.
References
- https://github.com/munkireport/comment/releases
- https://github.com/munkireport/munkireport-php
- https://github.com/munkireport/munkireport-php/releases/tag/v5.6.3
- https://github.com/munkireport/munkireport-php/wiki/20200722--XSS-Filter-Bypass-On-Comments
- https://github.com/munkireport/comment/releases
- https://github.com/munkireport/munkireport-php
- https://github.com/munkireport/munkireport-php/releases/tag/v5.6.3
- https://github.com/munkireport/munkireport-php/wiki/20200722--XSS-Filter-Bypass-On-Comments
Get alerted when CVE-2020-15885 or the next vulnerability affects your stack