What’s Vulnerable › Vulnerabilities
CVE-2020-15904
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-07-22 · updated 2026-06-17
- Weakness: CWE-787
Description
A buffer overflow in the patching routine of bsdiff4 before 1.2.0 allows an attacker to write to heap memory (beyond allocated bounds) via a crafted patch file.
Affected products
- Pypi Bsdiff4: before 1.2.0 — fixed in 1.2.0
How to fix
Upgrade to a fixed version: Pypi Bsdiff4 1.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/ilanschnell/bsdiff4/blob/master/CHANGELOG.txt
- https://github.com/ilanschnell/bsdiff4/commit/49a4cee2feef7deaf9d89e5e793a8824930284d7
- https://github.com/ilanschnell/bsdiff4/blob/master/CHANGELOG.txt
- https://github.com/ilanschnell/bsdiff4/commit/49a4cee2feef7deaf9d89e5e793a8824930284d7
Get alerted when CVE-2020-15904 or the next vulnerability affects your stack