What’s Vulnerable › Vulnerabilities
CVE-2020-16040
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 99.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-01-08 · updated 2026-06-17
- Weakness: CWE-20
Description
Insufficient data validation in V8 in Google Chrome prior to 87.0.4280.88 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.
Affected products
- Google Chrome: before 87.0.4280.88 — fixed in 87.0.4280.88
How to fix
Upgrade to a fixed version: Google Chrome 87.0.4280.88. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/162087/Google-Chrome-86.0.4240-V8-Remote-Code-Execution.html
- http://packetstormsecurity.com/files/162106/Google-Chrome-86.0.4240-V8-Remote-Code-Execution.html
- http://packetstormsecurity.com/files/162144/Google-Chrome-SimplfiedLowering-Integer-Overflow.html
- https://chromereleases.googleblog.com/2020/12/stable-channel-update-for-desktop.html
- https://crbug.com/1150649
- http://packetstormsecurity.com/files/162087/Google-Chrome-86.0.4240-V8-Remote-Code-Execution.html
- http://packetstormsecurity.com/files/162106/Google-Chrome-86.0.4240-V8-Remote-Code-Execution.html
- http://packetstormsecurity.com/files/162144/Google-Chrome-SimplfiedLowering-Integer-Overflow.html
- https://chromereleases.googleblog.com/2020/12/stable-channel-update-for-desktop.html
- https://crbug.com/1150649
Get alerted when CVE-2020-16040 or the next vulnerability affects your stack