What’s Vulnerable › Vulnerabilities
CVE-2020-16104
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-12-14 · updated 2026-06-17
- Weakness: CWE-89
Description
SQL Injection vulnerability in Enterprise Data Interface of Gallagher Command Centre allows a remote attacker with 'Edit Enterprise Data Interfaces' privilege to execute arbitrary SQL against a third party database if EDI is configured to import data from this database. This issue affects: Gallagher Command Centre 8.30 versions prior to 8.30.1236(MR1); 8.20 versions prior to 8.20.1166(MR3); 8.10 versions prior to 8.10.1211(MR5); 8.00 versions prior to 8.00.1228(MR6); version 7.90 and prior versions.
Affected products
- Gallagher Command Centre: before 7.90.0; from 8.00 before 8.00.1228; from 8.10 before 8.10.1211; from 8.20 before 8.20.1166; from 8.30 before 8.30.1236; 8.00.1228, 8.00.1228-maintenance_release6, 8.10.1211, 8.10.1211-maintenance_release5, 8.20.1166, 8.20.1166-maintenance_release3 (+2) — fixed in 7.90.0, 8.00.1228, 8.10.1211, 8.20.1166, 8.30.1236
How to fix
Upgrade to a fixed version: Gallagher Command Centre 7.90.0, 8.00.1228, 8.10.1211, 8.20.1166. Check the vendor advisory for mitigations.
References
- https://security.gallagher.com/Security-Advisories/CVE-2020-16104
- https://security.gallagher.com/Security-Advisories/CVE-2020-16104
Get alerted when CVE-2020-16104 or the next vulnerability affects your stack