What’s Vulnerable › Vulnerabilities
CVE-2020-16117
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-07-29 · updated 2026-06-17
- Weakness: CWE-476
Description
In GNOME evolution-data-server before 3.35.91, a malicious server can crash the mail client with a NULL pointer dereference by sending an invalid (e.g., minimal) CAPABILITY line on a connection attempt. This is related to imapx_free_capability and imapx_connect_to_server.
Affected products
- Debian Linux: 9.0
- GNOME evolution-data-server: before 3.35.91 — fixed in 3.35.91
How to fix
Upgrade to a fixed version: GNOME evolution-data-server 3.35.91. Check the vendor advisory for mitigations.
References
- https://gitlab.gnome.org/GNOME/evolution-data-server/-/commit/2cc39592b532cf0dc994fd3694b8e6bf924c9ab5
- https://gitlab.gnome.org/GNOME/evolution-data-server/-/commit/627c3cdbfd077e59aa288c85ff8272950577f1d7
- https://gitlab.gnome.org/GNOME/evolution-data-server/-/issues/189
- https://lists.debian.org/debian-lts-announce/2020/08/msg00005.html
- https://gitlab.gnome.org/GNOME/evolution-data-server/-/commit/2cc39592b532cf0dc994fd3694b8e6bf924c9ab5
- https://gitlab.gnome.org/GNOME/evolution-data-server/-/commit/627c3cdbfd077e59aa288c85ff8272950577f1d7
- https://gitlab.gnome.org/GNOME/evolution-data-server/-/issues/189
- https://lists.debian.org/debian-lts-announce/2020/08/msg00005.html
Get alerted when CVE-2020-16117 or the next vulnerability affects your stack