What’s Vulnerable › Vulnerabilities
CVE-2020-16250
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-08-26 · updated 2026-06-17
- Weakness: CWE-290
Description
HashiCorp Vault and Vault Enterprise versions 0.7.1 and newer, when configured with the AWS IAM auth method, may be vulnerable to authentication bypass. Fixed in 1.2.5, 1.3.8, 1.4.4, and 1.5.1..
Affected products
- HashiCorp Vault: from 0.7.1 before 1.2.5; from 1.3.0 before 1.3.8; from 1.4.0 before 1.4.4; from 1.5.0 before 1.5.1 — fixed in 1.2.5, 1.3.8, 1.4.4, 1.5.1
How to fix
Upgrade to a fixed version: HashiCorp Vault 1.2.5, 1.3.8, 1.4.4, 1.5.1. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/159478/Hashicorp-Vault-AWS-IAM-Integration-Authentication-Bypass.html
- https://github.com/hashicorp/vault/blob/master/CHANGELOG.md#151
- https://www.hashicorp.com/blog/category/vault/
- http://packetstormsecurity.com/files/159478/Hashicorp-Vault-AWS-IAM-Integration-Authentication-Bypass.html
- https://github.com/hashicorp/vault/blob/master/CHANGELOG.md#151
- https://www.hashicorp.com/blog/category/vault/
Get alerted when CVE-2020-16250 or the next vulnerability affects your stack