What’s Vulnerable › Vulnerabilities
CVE-2020-16253: PgHero gem allows CSRF
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-08-05 · updated 2026-06-17
- Weakness: CWE-352
Description
The PgHero gem through 2.6.0 for Ruby allows CSRF.
Affected products
- Pghero Project Pghero: through 2.6.0
- Rubygems Pghero: before 2.7.0; 0.0.1, 0.0.2, 0.0.3, 0.1.0, 0.1.1, 0.1.10 (+57) — fixed in 2.7.0
How to fix
Upgrade to a fixed version: Rubygems Pghero 2.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/ankane/pghero/
- https://github.com/ankane/pghero/issues/330
- https://github.com/ankane/pghero/
- https://github.com/ankane/pghero/issues/330
Get alerted when CVE-2020-16253 or the next vulnerability affects your stack