What’s Vulnerable › Vulnerabilities
CVE-2020-16270
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 13.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-10-16 · updated 2026-06-17
- Weakness: CWE-79
Description
OLIMPOKS under 3.3.39 allows Auth/Admin ErrorMessage XSS. Remote Attacker can use discovered vulnerability to inject malicious JavaScript payload to victim’s browsers in context of vulnerable applications. Executed code can be used to steal administrator’s cookies, influence HTML content of targeted application and perform phishing-related attacks. Vulnerable application used in more than 3000 organizations in different sectors from retail to industries.
Affected products
- Olimpoks Olimpok: before 3.3.39 — fixed in 3.3.39
How to fix
Upgrade to a fixed version: Olimpoks Olimpok 3.3.39. Check the vendor advisory for mitigations.
References
- https://bdu.fstec.ru/vul/2020-04623
- https://github.com/Security-AVS/CVE-2020-16270
- https://olimpoks.ru/oks/forum/olimpoks5.php
- https://bdu.fstec.ru/vul/2020-04623
- https://github.com/Security-AVS/CVE-2020-16270
- https://olimpoks.ru/oks/forum/olimpoks5.php
Get alerted when CVE-2020-16270 or the next vulnerability affects your stack